
     Jim McKnight    WindowsVista_Install.lwp  revised  1-27-2009

1. Make sure the Network Cable and all Printer Cables are disconnected from the P/C. 
2. Install WINDOWS VISTA from your Restore or Windows CD. (If this is a brand new PC,

start at step 2c.) 
a. See  www.blackviper.com/ for step-by-step install.  
b. If asked, uncheck the box that says: "� Automatically activate Windows when I'm online".  (You should wait

until all hardware is recognized and running under Vista before activating. You have 30 days. ).  
c. User Accounts: The Account you create during install, will be an Administrator Account. Use a User Name like

Admin - Jim (and a password if desired). (You will add your Standard User Account later from the Control
Panel.)

d. Enter a Computer Name (something like  DELL8400-PC) and choose a Desktop background for the
Administrator User Account. (A Computer Description (ie: Jim's Dell PC) will be added after install.) 

e.Windows Update Options: Click "Ask me later".
f.  If asked for your Location; For a Laptop, select "Public Location". For a Desktop PC,  select "Home". 
g. When Vista is done with all the "Install" reboots, you will end up at the Welcome Center of your Admin

Account.
h. If Norton Internet Security is on your computer, I suggest you uninstall it now. 
i. Create your main User Account (Standard user, not Administrator). (Control Panel > Add or remove user

accounts > Create a new account.).  Pick your preferred Account Name at this time. This is for the Account that
you plan to use all the time.  Warning: Plan to never change the account name. If you do, the C:\Users\<Your
Username> Folder name will not change.

3. SERVICE PACK 1:  If you have an SP1 CD/DVD, install it now then reboot.   

4. CUSTOMIZE THE MAIN "STANDARD USER" ACCOUNT: Log in to the main "Standard user"
Account that you just created (above) and continue with all the following steps: 

5. SYSTEM PROPERTIES optimizations:  .
a.  POWER PLAN: (Control Panel > System and Maintenance > Power Options)

1) Set "Power Plan" to High Performance (unless you run a lot on batteries), then customize settings as
desired: The "Power Button" action, the "Close Lid" action, "When to turn off the display" action, "When
the computer sleeps" action, and "Adjust the display brightness". 

2) Close the Power Options window with Red X or the Back button �.

b. COMPUTER NAME: (Control Panel < System and Maintenance > System).
1) Verify the Computer Name is what you want: (ie: DELL8400-PC), the Description is correct: (ie: Jim's Dell

PC), and the Workgroup is correct: ie:  JIMHOME . Note: All Workgroup Names on a home network
should be exactly the same. To change, click the Advanced system settings button. 

6. DISPLAY/DESKTOP Set-up: (Control Panel > Appearance and Personalization > Personalization)
a.MISC SETTINGS: 

1) DISPLAY SETTINGS: (Control Panel > Appearance and Personalization > Personalization > Display
settings).    
i. Click the Advanced Settings button, and on the “Monitor” Tab, make sure the Monitor Type matches

your Display. If it is only identified as "Generic" or "Default", you need to install the correct monitor
driver using the CD that came with your Monitor. (Insert CD, click Properties > Driver Tab > Update
Driver). 

ii. Monitor Tab, make sure to check the box “� Hide modes that this monitor cannot display”
iii. Monitor Tab, select the highest available refresh rate for your display (at least 75 Hz, if possible)
iv. When done, click <OK>, 
v. Select the best Resolution for your Monitor. Higher is better. For LCD's, select the "Native" Resolution.

Set Colors: Highest (32-bit). Click <OK> to exit.
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2) THEME: (Control Panel > Appearance and Personalization > Personalization > Theme). If desired, change
the Theme setting. Themes affect visuals, sounds, and other elements. Click OK to exit. (See my Vista Tips
for a guide on how the Themes and Color Schemes affect Vista speed.)   

3) COLOR SCHEME: (Control Panel > Appearance and Personalization > Personalization > Windows color
and appearance). If Aero is on, you will be at the "Windows color and appearance" window. If Aero is off,
you will be at the "Appearance Settings" window. If desired, change the Color Scheme here. (See the
"IMPROVE YOUR DISPLAY READABILITY section of my Vista Tips for details on Schemes & advanced
settings.")  

4) TRANSPARENCY (Vista Aero only):  (Control Panel > Appearance and Personalization > Personalization
> Windows color and appearance). If running Vista Aero, you can turn off Transparency at this time if
desired: (uncheck "� Enable transparency".  Click <OK> to exit).    

5) CLEARTYPE: If you are using an LCD or Plasma Monitor, you should turn on ClearType.  (Control Panel
> Appearance and Personalization > Personalization > "Open classic appearance properties for more color
options (Aero only)" > Effects). Check the box: “� Use the following method to smooth edges of screen
fonts”, and select “ClearType”.  

6) IMPROVE DISPLAY READABILITY:  If you want to customize various visual items to improve the
readability of the display, this is the time to do it. For detailed instructions, see the "IMPROVE YOUR
DISPLAY READABILITY" section of my "VISTA TIPS" Sheet.

7) DESKTOP BACKGROUND: (Control Panel > Appearance and Personalization > Personalization >
Desktop Background).  Browse and choose a background. Click <OK> to exit. 

8) SCREEN SAVER: (Control Panel > Appearance and Personalization > Personalization > Screen Saver).
Set up your Screen Saver settings.  All newer Monitors have a "Power Saver" feature, making a "Screen
Saver" unnecessary. If you want, just set the Screen Saver to "None" and in the Power Plan (Control Panel >
System and Maintenance > Power Options > "Choose when to turn off the display", choose: xx minutes.)  

b. ADD/REMOVE ICONS ON THE DESKTOP:
1) System Icons: Show System Icons onto the Desktop by (Right-click Desktop > Personalize > Change

Desktop Icons). Check boxes for all desired System Icons. 
2) Regular Icons: Create Shortcuts on the Desktop for any favorite Icons or Folders with a right-click and

drag.  
3) Special Icons: Such as the "Printers" Icon, can be found in the Control Panel's "Classic View" (ie: Control

Panel > Classic View > Printers). Right-click and drag all desired Icons to the Desktop.. When done, you
will want to restore the Control Panel to its "Vista Home" view (Control Panel > Control Panel Home).

4) Custom Folders: For a cleaner Desktop, you can create Custom Folders for storing similar Program
Shortcuts (Right-click Desktop > New > Folder). For example, I usually create a Desktop Folder called
"UTILITY Programs" for all my Utility, Anti-virus, and Anti-spy program Icons. I also customize this
UTILITY Programs Icon by (Right-click Icon > properties > Customize Tab > Change Icon button).
Select an Icon and click <OK>, <OK>. The new Icon image should be there. 

5) Delete any unwanted Icons from the Desktop.
c. REBOOT: Be sure to Reboot at this point and then make sure all the new settings took correctly. 

7. MOUSE optimizations:   (Control Panel > Hardware and Sound > Mouse)
a.Buttons Tab: Set “double click”= slowest.
b.Pointers Tab: Select the LARGE or EXTRA LARGE Scheme or load and select a custom Pointer by browsing

for it. For better visibility, check the box "� Enable pointer shadow".
c.Pointer Options Tab:  Set “pointer speed” = medium to fast. Under “Snap To”, check the box "� Automatically

move pointer to default". For better visibility: Check the box "� Display pointer trails" and set as desired. 
d.Wheel Tab:   Set Wheel to “3 lines at a time”
e.Device Settings Tab: If on a Laptop, I suggest you disable the "Tap to Click" setting. (The name varies with the

hardware). 
f. Click <Apply> & <OK> to exit.     
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8. FOLDER OPTIONS SET-UP 
a. Default Folder View: This sets the preferred Default view for ALL folders. First go to any Standard Folder and

choose your preferred view, then click; (Organize > "Folder and Search Options" > View tab.  Click <Apply to
Folders>).  NOTE: Later you can change the view on each individual folder and Vista will remember. 

b. Folder View Options: (Control Panel > Appearance and Personalization > Folder Options > View Tab). In the
"Advanced settings" box, make sure the boxes below are checked as follows: 
  Check the following boxes:
� Display simple folder view in Navigation Pane.
 � Show Hidden files and Folders.

  Uncheck the following box:
� Hide extensions for known file types  

  Check the following boxes:
� Hide protected operating system files.
� Remember each folder's view settings.
� Show Drive Letters.
� Show encrypted or compressed NTFS Folders & files in color.   

9. WELCOME CENTER:  (Control Panel > System and Maintenance > Welcome Center).  After a 2nd
boot, you can stop the Welcome center from opening on each bootup by un-checking the box: "� Run at startup" in
the lower left of the Welcome center window.    

10.  DEVICE MANAGER:  (Control Panel > System and Maintenance > Device Manager). Look to make
sure there are no devices with exclamation marks, question marks, or X’s. If so, delete the bad entries and reboot to
see if VISTA can re-detect & re-install the devices OK.  Fix these issues before continuing. 

11.  REMOVE ANY UNNECESSARY PROGRAMS & FEATURES: . 
a.  (Control Panel > Programs > Programs and Features): Remove all unwanted programs including any Trial

programs like Norton or AOL. NOTE: Be sure to RESTART after each program removal.
b. Optional: Click “Turn Windows features on or off” on the left side panel.  You’ll get a list of Windows built-in

software, much of which you’ll never use. If you are knowledgable, you can uncheck whatever you don’t need.
See  www.blackviper.com for a list.

12.  START MENU: 
a. Find the "Windows Explorer" Icon (Start>All Programs>Accessories). Right-click on the Icon & select "Pin to

Start Menu". 
b. Find the “Command Prompt” Icon (Start>All Programs>Accessories).  Right-click on the Icon & select "Pin to

Start Menu”. Right-click on the new "Command" Icon in the Start Menu and click  (Properties > Shortcut tab >
Advanced button) and select  "� Run as Administrator". 

c. Remove any unwanted Icons from the Start Menu. 

13.  TASKBAR: 
a. Right-click any blank area of the Taskbar. Click Toolbars, then click (to uncheck) any undesired Toolbars like

"Yahoo or Google Search".  If not already checked, click: "�Lock the Taskbar". 
b. Quick Launch Bar: Add any desired Icons to the Quick Launch Bar by right-clicking the desired Icon on the Start

Menu or Desktop and clicking "Add to Quick Launch". If you cannot see the new Icons in the Quick Launch,
unlock the Taskbar, drag the Separator to the right until they are all visible, then relock the Taskbar.

14.  WINDOWS FIREWALL: Make sure the Windows Firewall is turned on.  (Control Panel> Security >
Windows Firewall). 

15.  AUTOMATIC UPDATES, CONFIGURE:  (Control Panel > Security > Under "Security Center",
click "Turn Automatic updating on or off").  For most users, the best setting is "Automatic".  Be sure to check
the boxes for : "� Include recommended updates........" and "� Use Microsoft update".   

16.  CONNECT TO THE NETWORK NOW. (To continue, you must be on the internet.)   
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17.  GOBACK (optional): If desired, install the GoBack Program now. Then reboot. Then do "Live Update" to
get the latest version. Then disable Windows Restore: (Right-click Computer > Properties > System Protection >
System Protection Tab) and uncheck all drives under "Automatic restore points". (NOTE: You do not want two
different restore programs running. Choose one or the other).    

18.  RESTORE POINT: This is the time to create a Restore Point:  To create a Windows Restore point: (Control
Panel > System and maintenance > Backup and restore center > "Create a restore point or change settings").   To
create a "GOBACK" restore point, do a shutdown/power down and power up.

19.  WINDOWS UPDATE. Run Windows Update from (Control Panel > Security > Check for updates).
a. Keep re-running "Check for updates" until no more "Important" Updates are found.  Warning: Be sure to do a

“Shutdown/Power Down” after each batch of updates to make sure the downloaded ones have installed before
downloading more.  A "Restart" may NOT do the trick. 

b. Look at the "Recommended" and "Optional" updates by clicking "view available updates". Double-click each
update to see more information about it. Click the box for each one you want to install, then click the <Install>
button. "Recommended" updates are usually suggested software updates to fix bugs and improve reliability of
Vista. "Optional" updates are usually hardware driver updates of some sort. (Neither of these are mandatory.)  To
see if features (like .net Framework 3.0) are installed, go to  Control Panel > Programs > Programs and
Features > "Turn Windows features on or off" and look at the list of installed features. 

c. Make sure the Windows Security Center is happy. (Control Panel > Security > Security Center). 

20.  ACTIVATE VISTA:  (Control Panel > System and maintenance > System) or (search: slui ). 

21.  FIREFOX:  If desired, from the Administrator Account, install Firefox, then:  
a. Restore the Bookmarks and Add-on's:

1) If available, run MOZBACKUP to restore all settings (or import your back-up Bookmarks exported from
your old system).  

2) Verify that MOZBACKUP restored all FIREFOX Extensions OK.  If not, then manually reinstall them.
b. Make sure the “Download Options” setting is:   “� Always ask me where to save files”.  (Firefox: Tools >

Options > Main > Downloads).    
c. Set up all Firefox Options.  See "Firefox Configuration" on my FIREFOX TIPS Sheet.
d. Be sure to do the Adobe reader fix for Firefox PDF's. See my FIREFOX TIPS Sheet.   

22.  THUNDERBIRD: From the Administrator Account, install Thunderbird, then: 
a. Restore mail Settings, Address books and Mail Messages.

1) If available, run MOZBACKUP to restore each Thunderbird profile’s data including all Settings, Address
Books, Mail Folders, and E-mail. 

2) If MOZBACKUP is not available, import your previously "exported" Address Books from your old system
(and say “so long” to your old email).

b. Manually restore the "backed up" and saved Signature file from your old system to
c:\Users\<UserName>\AppData\Roaming\Thunderbird\Signaturexxx.html or put in your Documents folder.

c. If no backups, manually configure the email setup for Thunderbird. See my Thunderbird Configuration Sheet for
full instructions.. 

d. If you are trying to import an Outlook.pst file to Thunderbird, you will need to import it into the Outlook 2007
program first so the Thunderbird Import Wizard can find it. If Outlook 2007 is not installed, you may be
stuck.(Outlook 2003 may work)

23.  WINDOWS MAIL or OUTLOOK 2007 (Windows mail replaces Outlook Express)  If not using
Thunderbird, configure one of these Mail clients.  For Windows Mail, hopefully you have a backed up copy of
your exported “Outlook.pst” file from your old Outlook or Outlook Express. See microsoft article KB #196492.).
If you will use Windows Mail, you will need to import your Outlook.pst file into Outlook2007 first, then import
that into Windows Mail. My understanding is that Outlook 2003 will not do the job.    
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24.  MULTIMEDIA UTILITIES:  From the Administrator Account, install and/or verify the latest version is
installed of:

a. JAVA   Note: You may have to use IE7 instead of Firefox to install JAVA and you may have to do it from an Admin user.

b. Adobe FLASH (for Firefox)
c. Adobe FLASH (for IE) 
d. ADOBE READER
e. DirectX 10
f. and if desired: Adobe SHOCKWAVE,  WINAMP,  QUICKTIME,  & Realplayer Alternative (Be sure to

RESTART the PC after each one.).    

25.  ANTI-MALWARE: Download and install the following Utilities.  Details are on the  VIRUS~ MALWARE
TOOLS & TIPS sheet at www.jrmcknight.net.
a. AVG FREE 8.0 .  From the Administrator Account, download & install AVG Free (or your preferred) Antivirus

(AVG Free is from  http://free.grisoft.com/doc/1 ),  then check & re-check for online updates until no more
show up. Check & re-check for online updates until no more show up.  Make sure the Windows Security
Center is happy (No RED shield). Be sure to configure AVG per the VIRUS~MALWARE TOOLS & TIPS
sheet at www.jrmcknight.net.

b. SPY-BOT Search & Destroy      
c. SPYWARE BLASTER 
d. SECUNIA PERSONAL SOFTWARE INSPECTOR  
e. McAfee SITE ADVISOR (separately for IE and for Firefox) Note: Site Advisor does not play well with AVG

8.0.

26.  WINDOWS MEDIA PLAYER: Open WMP, configure & update. Be sure to UN-CHECK the box         
"� Download Usage rights automatically.....".

27.  WINDOWS/MSN MESSENGER: Open Messenger, configure your Logon and import your saved
contacts from the Backup Disk or CD.  

28.  ADOBE PHOTOSHOP ELEMENTS: Install & do the Web updates. (Do this before doing the
printer driver installs because of PIM II ).

29.  PRINTER SOFTWARE & DRIVERS:   Warning: Install from Printer CD’s only if the label says it
supports Vista!   Do not connect your printer until instructed by the Install Wizard!!! 

a. Be sure to download and install all the latest drivers, patches, and printer software from your Printer mfg’s
Website, not from the Printer's CD.  Note: EPSON Printers: You can restore EPSON printing preferences from
your Backup drive or CD to C:\ProgramData\EPSON\<YourPrinter>\xxxxxxxx.ucf (.UCF Files are the Printer
Preferences files for Epson Printers.)

b. If you have multiple printers, be sure to select which printer is to be the DEFAULT printer.
c. From each printer’s Properties Window, send a Test Page to the printer.

30.  MAJOR APPLICATION PROGRAMS, as desired:  
a. MICROSOFT OFFICE 200x from CD. Do Windows Updates several times to get all Office Updates. Be sure to

ACTIVATE Microsoft Office. 
b. POWERPOINT VIEWER, download from support.microsoft.com and install, ppviewer.exe 
c. LOTUS SMARTSUITE from CD. Set up Wordpro preferences Toolbars, Smarticons, etc.  
d. PRINTSHOP from CD.
e. ROXIO CD CREATOR 10.0  or NERO
f. POWER DVD. 
g. ACRONIS TRUE IMAGE        

31.  MISC UTILITIES: From the Administrator Account, install the following. (See the UTILITY PROGRAMS
sheet for details:
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a. CODESTUFF STARTER 
b. BELARC ADVISOR  
c. SI SANDRA  
d. CCLEANER             

32.  USER APPLICATION PROGRAMS: From the Administrator Account, install User programs like: 
a. SKYPE from www.skype.com (Skip the new user screens and then set up your log-on data)
b. Photo Programs.
c. Audacity.

33.  APPLICATION PROGRAM UPDATES: Do a "Check for Updates" on ALL application
programs.

34.  EVENT VIEWER: Review the Event Viewer logs and resolve any errors found. (Right-click Computer >
Manage > Event Viewer). Check both System and Application Logs for errors.  

35.  ANTI-VIRUS ANTI-SPYWARE SCANS: Run a full set of Anti-malware scans, including Defender &
the Secunia Personal Software Inspector.

36.  TESTING: 
a. Verify that all user data files are accessible from each and every Application Program.
b. Check that sounds are working OK. Windows Media Player should work.
c. Try test prints from each application program to each printer
d. Try a test scan on any Scanners.  
e. Load & play a Music CD. 
f. Test that a DVD movie plays OK
g. Try burning a CD & DVD.
h. Test all email functions and verify that the Signature file works OK.   

37.  Set up ADDITIONAL USERS. 
a. From the Administrator Account, create any other User Accounts (All should be Standard)
b. Repeat Step 6 (Display/Desktop Set-up) for each User. 
c. See my Vista Tips sheet for copying user profiles from one account to another. 
d. Configure Windows Mail or Thunderbird email for each User. (For Thunderbird, see my Thunderbird

Configuration Checklist). 
e. Select the default Printer for each user.  

38.  DEFRAG: Note: Vista continuously defrags the C Drive. If you want to do a manual defrag , use the Command
prompt. This is the only way can get a Report:  Be sure to right-click the "Command Prompt" Icon, then click "Run
as Aministrator" or it will fail to run. 

defrag c:  -a  -v      gives you an analysis and a report
defrag c:  -w  -v     gives you a full defrag and a report
defrag c:  - ?          gives you a list of all available options.

39.  HIBERNATE & STANDBY: Verify that “Hibernate” and “Standby” both work OK.

40.  BACKGROUND PROGRAMS: Turn off any unnecessary background programs or services using the
“STARTER” Utility Program. (See www.blackviper.com  for Windows services.) 

41.  BACKUP's: At this point it is a good idea to measure your new boot up time and then do a full image back-up
of your new install to an external Hard-drive as well as User data backup to CD or DVD to save off-site for safe
keeping.   
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